您的位置:首页 > 其它

HDOJ1879 继续畅通工程

2017-08-21 09:35 204 查看
继续畅通工程

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 26168 Accepted Submission(s): 11072

Problem Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。

Output

每个测试用例的输出占一行,输出全省畅通需要的最低成本。

Sample Input

3

1 2 1 0

1 3 2 0

2 3 4 0

3

1 2 1 0

1 3 2 0

2 3 4 1

3

1 2 1 0

1 3 2 1

2 3 4 1

0

Sample Output

3

1

0

Author

ZJU

Source

浙大计算机研究生复试上机考试-2008年

Recommend

We have carefully selected several similar problems for you: 1875 1301 1325 1198 3371

赤裸裸的最小生成树问题

#include <iostream>
#include <ctime>
#include <cstring>
#include <cmath>
using namespace std;

const int inf = 1<<30;
const int maxn = 102;
int a[maxn][maxn],tot,i,j,k,n;
int dis[maxn];
bool used[maxn];

void init(){
int x,y,z,f;
memset(a,-1,sizeof(a));
tot = 0;
k = n*(n-1)/2;

for (i=1; i<=k; i++) {
cin >> x >> y >> z >> f;
if (!f)  a[x][y] = a[y][x] = z;
else a[x][y] = a[y][x] = 0;
}

for (i=1; i<=n; i++) dis[i] = inf;
for (i=1; i<=n; i++) used[i] = 0;
}

void prim(){
int s = 1,min_dis;
used[s] = 1; dis[s] = 0;
tot = 0;
for (j=1; j<n; j++) {
for (i=1; i<=n; i++) if (a[s][i]!=-1 ) dis[i] = min(dis[i],a[s][i]);
min_dis = inf;
for (i=1; i<=n; i++) {
if (min_dis > dis[i] && !used[i]) {
s = i;
min_dis = dis[i];
}
}
used[s] = 1;
tot += dis[s];
}

}
ce2b

int main(){
std::ios::sync_with_stdio(false);
while(cin >> n && n){
init();
prim();
cout << tot << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: