您的位置:首页 > 其它

HDOJ1856 并查集水题

2017-08-20 23:48 387 查看


More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)

Total Submission(s): 29577    Accepted Submission(s): 10510


Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

 

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 

 

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

 

Sample Output

4
2

Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

 

Author

lxlcrystal@TJU

 

Source

HDU 2007 Programming Contest - Final

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1325 1879 1875 1198 1301 

只要注意一个地方就够了,n==0时,输出1!!!!

在这里WA了一次。。。

#include <iostream>
#include <ctime>
#include <cstring>
#include <cmath>
using namespace std;

const int inf = 1<<30;
const int maxn = 1e5+5;
int n,i,j,k,MIN,MAX,a,b,max_num;
int root[maxn],f[maxn];

void init(){
for (i=1; i<maxn; i++) root[i] = i;
memset(f,0,sizeof(f));
MIN = inf;
MAX = 0;
}

int Find(int x){
int r = x;
while (r!=root[r]) r = root[r];
int i = x, k;
while (root[i] != r) {
k = root[i];
root[i] = r;
i = k;
}
return r;
}

void Merge(int x, int y){
int fx = Find(x), fy = Find(y);
if (fx!=fy) root[fx] = fy;
}

int main(){
std::ios::sync_with_stdio(false);
while (cin >> n){
if (n==0) {
cout << 1 << endl;
continue;
}
init();
for (i=1; i<=n; i++) {
cin >> a >> b;
MIN = min(a,MIN); MIN = min(b,MIN);
MAX = max(a,MAX); MAX = max(b,MAX);
Merge(a,b);
}
max_num = 0;
for (i=MIN; i<=MAX; i++) f[Find(i)]++;
for (i=MIN; i<=MAX; i++) max_num = max(max_num,f[i]);
cout << max_num << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: