您的位置:首页 > 其它

B - Girls and Boys(二分图与匈牙利算法)

2017-08-20 16:31 323 查看
点击打开链接

Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find
out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set. 

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

the number of students 

the description of each student, in the following format 

student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 

or 

student_identifier:(0) 

The student_identifier is an integer number between 0 and n-1, for n subjects. 

For each given data set, the program should write to standard output a line containing the result. 

 

Sample Input

 7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

 

Sample Output

 5
2

 

题解:0: (3) 4 5 6 的意思是0-5,0-4,0-6匹配

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[505],fr[505][505];
int vis[505];
int n;
bool find(int x)
{
for(int i=0;i<n;i++)
{
if(fr[x][i]&&!vis[i])
{
vis[i]=true;
if(f[i]==-1||find(f[i]))
{
f[i]=x;
return true;
}
}
}
return false;
}
int main()
{

while(scanf("%d",&n)!=EOF)
{
memset(f,-1,sizeof(f));
memset(fr,false,sizeof(fr));
for(int i=1;i<=n;i++)
{
int a,b;
scanf("%d: (%d)",&a,&b);
while(b--)
{
int t;
scanf("%d",&t);
fr[a][t]=true;
fr[t][a]=true;
}
}
int ans=0;
for(int i=0;i<n;i++)
{
memset(vis,false,sizeof(vis));
if(find(i))
ans++;
}
ans=n-(ans/2);
//顶点数 - 最大配对数 = 最大独立集数(因为是把集合扩大了1倍,所以除以2)
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: