您的位置:首页 > 其它

【HDU-3336-count the string】(KMP)

2017-08-20 08:55 351 查看
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: “abab”

The prefixes are: “a”, “ab”, “aba”, “abab”

For each prefix, we can count the times it matches in s. So we can see that prefix “a” matches twice, “ab” matches twice too, “aba” matches once, and “abab” matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For “abab”, it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

Input

The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

Sample Input

1

4

abab

Sample Output

6

解析:

/*

因为next数组表示的是子串中最长公共前后缀串的长度,

如果用dt[i]表示该字符串前i个字符中出现任意以第i个字符结尾的前缀的次数,

它的递推式是 dt[i]=d[next[i]]+1,

即以第i个字符结尾的前缀数等于以第next[i]个字符为结尾的前缀数加上它自己本身

*/

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char str1[200010];
int next1[200010];
int N;
int dt[200010];
void get_next()
{
int i=0,j=0;
next1[i]=-1;
j=next1[i];
while(i<N)
{
if(j==-1||str1[i]==str1[j])
next1[++i]=++j;
else j=next1[j];
}
}
/*
因为next数组表示的是子串中最长公共前后缀串的长度,
如果用dt[i]表示该字符串前i个字符中出现任意以第i个字符结尾的前缀的次数,
它的递推式是 dt[i]=d[next[i]]+1,
即以第i个字符结尾的前缀数等于以第next[i]个字符为结尾的前缀数加上它自己本身
*/
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&N);
scanf("%s",str1);
memset(dt,0,sizeof(dt));
get_next();
int  sum=0;
for(int i=1;i<=N;i++)
{
dt[i]=dt[next1[i]]+1;
sum=(sum+dt[i])%10007;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kmp