您的位置:首页 > 其它

【poj-2406-powerstring】(KMP)

2017-08-20 08:46 274 查看
Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd

aaaa

ababab

.

Sample Output

1

4

3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

解析:

总结一下,如果对于next数组中的 i, 符合 i % ( i - next[i] ) == 0 && next[i] != 0 , 则说明字符串0-n-1循环,而且

循环节长度为: i - next[i]

循环次数为: i / ( i - next[i] )

如果要问为什么可以自习用几个栗子,然后啃一啃

或者看这里:

next[i]数组的含义是0-i-1个字符中前next[i]和倒数next[i]是完全相同的,

那么如果next[i] < (i-1)/2 (即如果这完全相同的前缀和后缀不重合的话)

那么有i-next[i]>(i-1)/2则i不可能有i%[i-next[i]]==0这种情况是不可能有循*环串的,*

因为如果是循环串,公共的前缀和后缀肯定是重合的

下面考虑如果重合的情况,如果重合的话,那么一定有i-next[i]就是最小的循环节长度

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char str[1000010];
int next[1000010],m;
void get_next()
{
int j=0,i=0;
next[i]=-1;
j=next[i];
while(i<m)
{
if(j==-1||str[i]==str[j])
next[++i]=++j;
else j=next[j];
}
}
/*
总结一下,如果对于next数组中的 i, 符合 i % ( i - next[i] ) == 0 && next[i] != 0 , 则说明字符串0-n-1循环,而且

循环节长度为:   i - next[i]

循环次数为:       i / ( i - next[i] )

如果要问为什么可以自习用几个栗子,然后啃一啃

或者看这里:

next[i]数组的含义是0-i-1个字符中前next[i]和倒数next[i]是完全相同的,
那么如果next[i] < (i-1)/2 (即如果这完全相同的前缀和后缀不重合的话)
那么有i-next[i]>(i-1)/2则i不可能有i%[i-next[i]]==0这种情况是不可能有循环串的,
因为如果是循环串,公共的前缀和后缀肯定是重合的
下面考虑如果重合的情况,如果重合的话,那么一定有i-next[i]就是最小的循环节长度

*/
int main()
{
while(~scanf("%s",str)&&strcmp(str,"."))
{
m=strlen(str);
get_next();
if(m%(m-next[m])==0)
printf("%d\n",m/(m-next[m]));
else printf("1\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  kmp