您的位置:首页 > 其它

POJ 3352 Road Construction (边双连通分量)

2017-08-19 17:21 507 查看
Road Construction

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 12330 Accepted: 6192
Description

It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between
the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between
two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist
attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration,
if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions
are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w.
Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input
Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output
Output for Sample Input 1
2

Output for Sample Input 2
0

Source
CCC 2007

若使任意一棵树,在增加若干条边后,变成一个双连通图,至少增加的边数 =( 这棵树总度数为1的结点数 + 1 )/ 2

任意两个节点之间不会出现重边时,Tarjan算法在经DFS,若两节点low值相同,则两个结点必定在同一个边双连通分量中;如果是有重边的话,若两节点low值不同也可能属于同一个边双连通分量

本题无重边

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <vector>
#include <stack>
#define maxn 3030
typedef long long ll;
using namespace std;
int n,r,index,sum;
vector<int>g[1010];
stack<int>s;
int dfn[1010],low[1010],belong[1010],instack[1010];
int degree[1010];
void tarjan(int x,int f)
{
int i,j;
low[x]=dfn[x]=++index;
instack[x]=1;
for(i=0;i<g[x].size();i++)
{
int k=g[x][i];
if(k==f)
continue;
if(!dfn[k])
{
tarjan(k,x);
low[x]=min(low[x],low[k]);
}
else if(instack[k])
low[x]=min(low[x],dfn[k]);
}
}
int main()
{
int t,i,j,a,b;
scanf("%d %d",&n,&r);
for(i=1;i<=r;i++)
{
scanf("%d %d",&a,&b);
g[a].push_back(b);
g[b].push_back(a);
}
tarjan(1,-1);
for(i=1;i<=n;i++)
{
for(j=0;j<g[i].size();j++)
{
int k=g[i][j];
if(low[i]!=low[k])
{
degree[low[i]]++;
}
}
}
int ans=0;
for(i=1;i<=n;i++)
{
if(degree[i]==1)
ans++;
}
printf("%d\n",(ans+1)/2);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: