您的位置:首页 > 其它

【并查集】POJ_1456_Supermarket

2017-08-19 10:39 363 查看
Supermarket

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13518 Accepted: 6104
Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time
for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is
Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 

For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts
at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 



Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product.
White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
5 20  50 10

Sample Output
80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.
Source

Southeastern Europe 2003
/*
用并查集把直接贪心O(n^2)的复杂度降到O(nlogn),妙啊!
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=10010;
int f[maxn];
struct node{
int v,d;
}p[maxn];
int cmp(struct node a,struct node b){
return a.v>b.v;
}
void Init(){
for(int i=0;i<=10001;i++)
f[i]=i;
}
int Find(int x){
if(f[x]!=x)
f[x]=Find(f[x]);
return f[x];
}
int main()
{
int n;
while(~scanf("%d",&n)){
Init();
for(int i=0;i<n;i++)
scanf("%d%d",&p[i].v,&p[i].d);
sort(p,p+n,cmp);
int ans=0;
for(int i=0;i<n;i++){
int fx=Find(p[i].d);
if(fx!=0){
ans+=p[i].v;
f[fx]=fx-1;
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: