您的位置:首页 > 其它

Til the Cows Come Home POJ - 2387

2017-08-19 09:23 183 查看
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various
lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input
* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100


Sample Output
90


Hint
INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.
题意概括:n个地方t条路,问从n到1的最短路径。

解题思路:因为问的是n到1的最短路,相当于一个双向路,而且两个地方可能有多条路此时用距离最近的路。然后套用Dijkstra即可。

代码:#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f
#define N 2010
int t,n;
int line

;
int vis
,d
;
void Dijkstra()
{
int i,j;
memset(vis,0,sizeof(vis));
vis[1]=1;
for(i=1;i<=n;i++)
{
d[i]=line[1][i];
}
d[1]=0;

for(i=1;i<=n;i++)
{
int min_cost=INF;
int index;

fo
4000
r(j=1;j<=n;j++)
{
if(d[j]<min_cost&&vis[j]==0)
{
min_cost=d[j];
index=j;
}
}
vis[index]=1;
for(j=1;j<=n;j++)
{
if(vis[j]==0&&d[j]>line[index][j]+min_cost)
{
d[j]=line[index][j]+min_cost;
}
}
}
printf("%d\n",d
);
}
int main()
{
int i,j,u,v,w;
while(scanf("%d%d",&t,&n)!=EOF)
{
memset(line,INF,sizeof(line));
for(i=0;i<t;i++)
{
scanf("%d%d%d",&u,&v,&w);
if(w<line[u][v])
{
line[u][v]=line[v][u]=w;
}
}

Dijkstra();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: