您的位置:首页 > 其它

UVALive6336 HDU4450 Draw Something【水题】

2017-08-19 04:59 399 查看

Draw Something

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3698    Accepted Submission(s): 3089

Problem Description

Wangpeng is good at drawing. Now he wants to say numbers like “521” to his girlfriend through the game draw something.

Wangpeng can’t write the digit directly. So he comes up a way that drawing several squares and the total area of squares is the number he wants to say.

Input all the square Wangpeng draws, what’s the number in the picture?

[align=left]Input[/align]
There are multiple test cases.

For each case, the first line contains one integer N(1≤N≤100) indicating the number of squares.

Second line contains N integers ai(1≤ai≤100)represent the side length of each square. No squares will overlap.

Input ends with N = 0.

[align=left]Output[/align]
For each case, output the total area in one line.

[align=left]Sample Input[/align]

4
1 2 3 4
3
3 3 3
0

[align=left]Sample Output[/align]

30
27

[align=left]Source[/align]
2012 Asia JinHua
Regional Contest

Regionals 2012 >> Asia
- Jinhua


问题链接UVALive6336 HDU4450 Draw Something

问题简述:(略)

问题分析:(略)

程序说明:这里给出两个版本的程序。

题记:(略)

参考链接:(略)

AC的C语言程序如下:

/* UVALive6336 HDU4450 Draw Something */

#include <stdio.h>

int main()
{
int n;
while (scanf("%d", &n) != EOF) {
if(n == 0)
break;

int sum = 0;
for(int i=0; i<n; i++) {
int x;
scanf ("%d", &x);
sum += x * x;
}

printf ("%d\n", sum);
}

return 0;
}


AC的C++语言程序如下:

/* UVALive6336 HDU4450 Draw Something */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
int n, m, sum;
while (scanf("%d", &n) != EOF && n) {
sum = 0;
while(n--) {
scanf ("%d", &m);
sum += m * m;
}

printf ("%d\n", sum);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: