您的位置:首页 > Web前端

【并查集】POJ_2492_A Bug's Life

2017-08-18 20:44 435 查看
A Bug's Life

Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 39001 Accepted: 12669
Description

Background 

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy
to identify, because numbers were printed on their backs. 
Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each
interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual
behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
Source

TUD Programming Contest 2005, Darmstadt, Germany
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=2010;
int f[maxn],val[maxn],n,m;
void Init(){
for(int i=0;i<=n;i++){
f[i]=i;
val[i]=0;
}
}
int Find(int x){
if(f[x]!=x){
int tmp=Find(f[x]);
val[x]^=val[f[x]];
f[x]=tmp;
}
return f[x];
}
int main(){
int t,x,y;
scanf("%d",&t);
for(int cas=1;cas<=t;cas++){
scanf("%d%d",&n,&m);
Init();
int flag=1;
while(m--){
scanf("%d%d",&x,&y);
int fx=Find(x);
int fy=Find(y);
if(fx==fy){
if(val[x]==val[y])
flag=0;
}
else {
f[fx]=fy;
val[fx]=~(val[x]^val[y]);
}
}
printf("Scenario #%d:\n",cas);
if(flag) printf("No suspicious bugs found!\n\n");
else printf("Suspicious bugs found!\n\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: