您的位置:首页 > 其它

HDU-3333-Turing Tree-(树状数组,离散化)

2017-08-18 17:06 501 查看


Turing Tree

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5579    Accepted Submission(s): 1991


Problem Description

After inventing Turing Tree, 3xian always felt boring when solving problems about intervals, because Turing Tree could easily have the solution. As well, wily 3xian made lots of new problems about intervals. So, today, this sick thing happens again...

Now given a sequence of N numbers A1, A2, ..., AN and a number of Queries(i, j) (1≤i≤j≤N). For each Query(i, j), you are to caculate the sum of distinct values in the subsequence Ai, Ai+1, ..., Aj.

 

Input

The first line is an integer T (1 ≤ T ≤ 10), indecating the number of testcases below.

For each case, the input format will be like this:

* Line 1: N (1 ≤ N ≤ 30,000).

* Line 2: N integers A1, A2, ..., AN (0 ≤ Ai ≤ 1,000,000,000).

* Line 3: Q (1 ≤ Q ≤ 100,000), the number of Queries.

* Next Q lines: each line contains 2 integers i, j representing a Query (1 ≤ i ≤ j ≤ N).

 

Output

For each Query, print the sum of distinct values of the specified subsequence in one line.

 

Sample Input

2
3
1 1 4
2
1 2
2 3
5
1 1 2 1 3
3
1 5
2 4
3 5

 

Sample Output

1
5
6
3
6

 

Author

3xian@GDUT

 

Source

HDOJ Monthly Contest – 2010.03.06

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1542 3397 1698 1394 1540 

与题目hdu-3874-Necklace-(树状数组)相同,只是这里数据更大,需要借用STL的函数离散化处理,

lower_bound(begin, end, value); 返回>=value的元素的第一个位置。函数lower_bound()在first和last中的前闭后开区间进行二分查找,返回大于或等于val的第一个元素位置。如果所有元素都小于val,则返回last的位置

介绍lower_bound()的文章:http://blog.csdn.net/niushuai666/article/details/6734403

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iomanip>
#include<queue>
#include<cstring>
#include<map>
using namespace std;
typedef long long ll;
int n,m;
ll tree[30005],ans[100005];
int a[30005],vis[30005],b[30005],pos[30005];
struct node{
int s,e,id;
bool operator <(const node& b) const
{
return e<b.e||(e==b.e&&s<b.s);
}
}p[100005];
int lowbit(int i)
{
return i&(-i);
}
void add(int i,int v)
{
while(i<=n)
{
tree[i]+=v;
i+=lowbit(i);
}
}
ll sum(int i)  //一定注意i>=1,切记i不能为0
{
ll res=0;
while(i>0)
{
res+=tree[i];
i-=lowbit(i);
}
return res;
}
int main()
{
int i,T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
memset(tree,0,sizeof(tree));
memset(vis,0,sizeof(vis));
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
b[i]=a[i];
}
scanf("%d",&m);
for(i=1;i<=m;i++)
{
scanf("%d%d",&p[i].s,&p[i].e);
p[i].id=i;
}
sort(p+1,p+m+1);
sort(b+1,b+n+1);
for(i=1;i<=n;i++)
{
pos[i]=lower_bound(b+1,b+n+1,a[i])-b;
}
int it=1;
for(i=1;i<=m;i++)
{
while(it<=p[i].e)
{
if(vis[pos[it]]!=0)
{
add(vis[pos[it]],-a[it]);
}
vis[pos[it]]=it;
add(it,a[it]);
it++;
}
ans[p[i].id]=sum(p[i].e)-sum(p[i].s-1);
}
for(i=1;i<=m;i++)
{
printf("%I64d\n",ans[i]);
}
}
return 0;
}


参考博客:http://blog.csdn.net/just_water/article/details/9716983
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: