您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之查找三:树的种类统计

2017-08-18 15:58 211 查看


Problem Description

随着卫星成像技术的应用,自然资源研究机构可以识别每一个棵树的种类。请编写程序帮助研究人员统计每种树的数量,计算每种树占总数的百分比。


Input

输入一组测试数据。数据的第1行给出一个正整数N (n <= 100000),N表示树的数量;随后N行,每行给出卫星观测到的一棵树的种类名称,树的名称是一个不超过20个字符的字符串,字符串由英文字母和空格组成,不区分大小写。


Output

按字典序输出各种树的种类名称和它占的百分比,中间以空格间隔,小数点后保留两位小数。


Example Input

2
This is an Appletree
this is an appletree



Example Output

this is an appletree 100.00%

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

typedef struct tree
{
char data[25];
int num;
struct tree *lc, *rc;
} BiTree;

double x;

BiTree *Creat(BiTree *T, char *s)
{
if(T == NULL)
{
T = (BiTree*)malloc(sizeof(BiTree));
T->lc = NULL;
T->rc = NULL;
T->num = 1;
strcpy(T->data, s);
}
else
{
int k = strcmp(T->data, s);
if(k == 0)
T->num++;
else if(k > 0)
T->lc = Creat(T->lc, s);
else
T->rc = Creat(T->rc, s);
}
return T;
}

void Mid(BiTree *T)  //中序遍历输出树名和百分比
{
if(T)
{
Mid(T->lc);
printf("%s %.2lf%%\n", T->data, (T->num/x)*100);
Mid(T->rc);
}
}

int main()
{
int n, i;
char s[25];
BiTree *T;
T = NULL;
scanf("%d", &n);
x = n;       //全局变量double x保存n的值
getchar();   //吃掉回车键
while(n--)
{
gets(s);
for(i = 0;
965b
s[i] != '\0'; i++)
{
if(s[i] <= 'Z' && s[i] >= 'A')   //将所有大写转换成小写
s[i] = s[i] + 32;
}
T = Creat(T, s);
}
Mid(T);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: