您的位置:首页 > 其它

poj 3616 简单dp

2017-08-18 10:34 381 查看
Milking Time

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10486 Accepted: 4396
Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N),
and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending
hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that
Bessie can produce in the N hours.

Input

*
4000
Line 1: Three space-separated integers: N, M, and R

* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output
43

Source

USACO 2007 November Silver

虽说是简单dp,但我感觉和贪心差不多,

ac代码

#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <string>
#include <stack>
#include <queue>
#include <algorithm>
#include <map>
#define ll long long
#define inf 1e18+5

using namespace std;
int n,m,r;
int dp[1010];
struct node{
int star,end,val;
}nn[1010];

bool cmp(node a,node b){
if(a.star == b.star)
return a.end < b.end;
return a.star < b.star;
}

int main(){

while(~scanf("%d%d%d",&n,&m,&r)){
for(int i=1;i<=m;i++){
scanf("%d%d%d",&nn[i].star,&nn[i].end,&nn[i].val);
}
sort(nn+1,nn+1+m,cmp);
for(int i=1;i<=m;i++)
dp[i]=nn[i].val;
int mmax;
for(int i=2;i<=m;i++){
for(int j=1;j<i;j++){
if(nn[i].star >= nn[j].end + r)
dp[i]=max(dp[i],dp[j]+nn[i].val);
}
/*dp[i]=mmax+nn[i].val;*/
}
mmax=0;
for(int i=1;i<=m;i++)
mmax=max(mmax,dp[i]);

printf("%d\n",mmax);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: