您的位置:首页 > 其它

Hybrid Crystals (2017多校 第八场) (思维题 视力题)

2017-08-17 22:31 447 查看


Hybrid Crystals

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 335 Accepted Submission(s): 202



Problem Description

> Kyber crystals, also called the living crystal or simply the kyber, and known as kaiburr crystals in ancient times, were rare, Force-attuned crystals that grew in nature and were found on scattered planets across the galaxy. They were used by the Jedi and
the Sith in the construction of their lightsabers. As part of Jedi training, younglings were sent to the Crystal Caves of the ice planet of Ilum to mine crystals in order to construct their own lightsabers. The crystal's mix of unique lustre was called "the
water of the kyber" by the Jedi. There were also larger, rarer crystals of great power and that, according to legends, were used at the heart of ancient superweapons by the Sith.

>

> — Wookieepedia

Powerful, the Kyber crystals are. Even more powerful, the Kyber crystals get combined together. Powered by the Kyber crystals, the main weapon of the Death Star is, having the firepower of thousands of Star Destroyers.

Combining Kyber crystals is not an easy task. The combination should have a specific level of energy to be stablized. Your task is to develop a Droid program to combine Kyber crystals.

Each crystal has its level of energy (i-th
crystal has an energy level of ai).
Each crystal is attuned to a particular side of the force, either the Light or the Dark. Light crystals emit positive energies, while dark crystals emit negative energies. In particular,

* For a light-side crystal of energy level ai,
it emits +ai units
of energy.

* For a dark-side crystal of energy level ai,
it emits −ai units
of energy.

Surprisingly, there are rare neutral crystals that can be tuned to either dark or light side. Once used, it emits either +ai or −ai units
of energy, depending on which side it has been tuned to.

Given n crystals'
energy levels ai and
types bi (1≤i≤n), bi=N means
the i-th
crystal is a neutral one, bi=L means
a Light one, and bi=D means
a Dark one. The Jedi Council asked you to choose some crystals to form a larger hybrid crystal. To make sure it is stable, the final energy level (the sum of the energy emission of all chosen crystals) of the hybrid crystal must be exactly k.

Considering the NP-Hardness of this problem, the Jedi Council puts some additional constraints to the array such that the problem is greatly simplified.

First, the Council puts a special crystal of a1=1,b1=N.

Second, the Council has arranged the other n−1 crystals
in a way that

ai≤∑j=1i−1aj[bj=N]+∑j=1i−1aj[bi=L∩bj=L]+∑j=1i−1aj[bi=D∩bj=D](2≤i≤n).

[cond] evaluates
to 1 if cond holds,
otherwise it evaluates to 0.

For those who do not have the patience to read the problem statements, the problem asks you to find whether there exists a set S⊆{1,2,…,n} and
values si for
all i∈S such
that

∑i∈Sai∗si=k,

where si=1 if
the i-th
crystal is a Light one, si=−1 if
the i-th
crystal is a Dark one, and si∈{−1,1} if
the i-th
crystal is a neutral one.

Input

The first line of the input contains an integer T,
denoting the number of test cases.

For each test case, the first line contains two integers n (1≤n≤103)
and k (|k|≤106).

The next line contains n integer a1,a2,...,an (0≤ai≤103).

The next line contains n character b1,b2,...,bn (bi∈{L,D,N}).

Output

If there exists such a subset, output "yes", otherwise output "no".

Sample Input

2

5 9
1 1 2 3 4
N N N N N

6 -10
1 0 1 2 3 1
N L L L L D


Sample Output

yes
no


Source

2017 Multi-University Training Contest - Team 8

题目的重点就是这个公式:ai≤∑j=1i−1aj[bj=N]+∑j=1i−1aj[bi=L∩bj=L]+∑j=1i−1aj[bi=D∩bj=D](2≤i≤n).
①.a_1一定是1,它的下标一定是N。

②.【重点】给出后n-1个数的范围:a_i ≤ (j从1到i-1的)(所有下标为N的a_j之和)+ (a_i下标为L 并且 a_j下标为L的数值)+ (a_i下标为D 并且 a_j下标为D的数值)。然而这个条件有什么用呢?

它间接表明第一个下标为L的数,只能取0或1;

(在不出现N时)第二个下标为L的数只能是0或1或2;

(在不出现N时)第三个下标为L的数取值范围为0-4;

(在不出现N时)第四个下标为L的数取值范围为0-8;

所以题解说的 :

这道题中的数能组成的数构成了一个连续区间.

一开始只有 a1a​1​​ 的时候能够构成 [−1,1][−1,1] 中的所有整数.

如果一堆数能够构成 [−a,b][−a,b] 中的所有整数,
这时候来了一个数 xx.
如果 xx 只能取正值的话,
如果有 x≤bx≤b,
那么就能够构成 [−a,b+x][−a,b+x] 的所有整数.

如果 xx 只能取负值,
如果有 x≤yx≤y,
那么就能构成 [−a−x,b][−a−x,b] 的所有整数.

如果 xx 可正可负,
如果有 x≤min(x,y)x≤min(x,y),
那么就能构成 [−a−x,b+x][−a−x,b+x] 中的所有整数.

然后题目中那个奇怪的不等式就保证了上面的"如果有"的条件.

这就像二进制的 第i位的值 == 前i位的和 + 1; 能组成一个区间内的所有值;

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <cmath>
#include <vector>
#include <utility>
#include <queue>
using namespace std;
int main() {
//freopen("in.txt", "r", stdin);
int a[1005];
char ch[1005];
int t;
int n, k;
cin >> t;
while (t--) {
cin >> n >> k;
for (int i = 0; i < n; ++i) {
cin >> a[i];
}

for (int i = 0; i < n; ++i) {
cin >> ch[i];
}
int sum = 0;
if (k >= 0) {
for (int i = 0; i < n; ++i) {
if (ch[i] == 'N' || ch[i] == 'L') {
sum += a[i];
}
}
if (sum >= k) {
cout << "yes" << endl;
} else
cout << "no" << endl;
} else {
for (int i = 0; i < n; ++i) {
if (ch[i] == 'D' || ch[i] == 'N') {
sum -= a[i];
}
}
if (sum <= k) {
cout << "yes" << endl;
} else
cout << "no" << endl;
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: