您的位置:首页 > 其它

poj 3261 Milk Patterns (后缀数组+二分)

2017-08-17 22:06 477 查看
Milk Patterns

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 16058 Accepted: 7075
Case Time Limit: 2000MS
Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk
quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He
wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K 

Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.
Output

Line 1: One integer, the length of the longest pattern which occurs at least K times
Sample Input
8 2
1
2
3
2
3
2
3
1

Sample Output
4

Source

USACO 2006 December Gold

这题是求可重叠的k次最长子串。

思路:这题在二分的时候要注意height数组存的是sa[i-1]和sa[i]的最长公共前缀的长度,所以当遇到不符合要求的时候要重新开始计数。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_N 1000005
using namespace std;
int s[MAX_N];
int wa[MAX_N],wb[MAX_N],wv[MAX_N],wss[MAX_N];
int sa[MAX_N],ran[MAX_N],height[MAX_N];
int cmp(int *r,int a,int b,int l)
{
return r[a]==r[b]&&r[a+l]==r[b+l];
}
void da(int *r,int *sa,int n,int m)
{
int i,j,p,*x=wa,*y=wb,*t;
for(i=0;i<m;i++) wss[i]=0;
for(i=0;i<n;i++) wss[x[i]=r[i]]++;
for(i=1;i<m;i++) wss[i]+=wss[i-1];
for(i=n-1;i>=0;i--) sa[--wss[x[i]]]=i;
for(j=1,p=1;p<n;j*=2,m=p)
{
for(p=0,i=n-j;i<n;i++) y[p++]=i;
for(i=0;i<n;i++) if(sa[i]>=j) y[p++]=sa[i]-j;
for(i=0;i<n;i++) wv[i]=x[y[i]];
for(i=0;i<m;i++) wss[i]=0;
for(i=0;i<n;i++) wss[wv[i]]++;
for(i=1;i<m;i++) wss[i]+=wss[i-1];
for(i=n-1;i>=0;i--) sa[--wss[wv[i]]]=y[i];
for(t=x,x=y,y=t,p=1,x[sa[0]]=0,i=1;i<n;i++)
x[sa[i]]=cmp(y,sa[i-1],sa[i],j)?p-1:p++;
}
}
void callheight(int *r,int *sa,int n)
{
int i,j,k=0;
for(i=1;i<=n;i++)
ran[sa[i]]=i;
for(i=0;i<n;height[ran[i++]]=k)
for(k?k--:0,j=sa[ran[i]-1];r[i+k]==r[j+k];k++);
return ;
}
int jud(int mid,int n,int k)
{
int cnt=1;
for(int i=2;i<=n;i++)
{
if(height[i]>=mid)
{
cnt++;
if(cnt>=k) return 1;
}
else cnt=1;//重新进行计算
}
return 0;
}
int main()
{
int n,k;
while(~scanf("%d%d",&n,&a
bd73
mp;k))
{
for(int i=0;i<n;i++)
scanf("%d",&s[i]),s[i]++;
s
=0;
da(s,sa,n+1,MAX_N);
callheight(s,sa,n);
int l=1,r=n,mid;
while(l<=r)
{
mid=(l+r)/2;
if(jud(mid,n,k))
l=mid+1;
else
r=mid-1;
}
printf("%d\n",r);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: