您的位置:首页 > 其它

HDU-4764-Stone 【巴什博弈】

2017-08-17 20:38 225 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4764


Stone

Problem Description

Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming
that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number
only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.

 

Input

There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.

 

Output

For each case, print the winner's name in a single line.

 

Sample Input

1 1
30 3
10 2
0 0

 

Sample Output

Jiang
Tang
Jiang

 

题目分析:两个人轮流写数字,Tang先写,每次写的数x满足1<=x<=k,另一个人每次写的数y满足1<=y-x<=k,谁先写到>=n的数就算输。 其实就是拿n-1个石头的巴什博弈

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0)
break;
if((n-1)%(m+1)==0)
cout<<"Jiang"<<endl;
else
cout<<"Tang"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: