您的位置:首页 > 其它

HDU 1069 Monkey and Banana 最长上升子序列模板

2017-08-17 17:18 465 查看


Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16198    Accepted Submission(s): 8618


Problem Description

A group of researchers
4000
are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana
by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

 

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

 

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

 

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

 

Source

University of Ulm Local Contest 1996

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1087 1058 1231 1024 1421 

 
打算好好写写这个题的博客,因为自己手残这个模板题写了一下午,太浪费时间了,不过记住了这次的错误,
很简单,就是跟你n种木块吧,每个块有六个面,每个面都可以朝下,讲道理应该是有三种放的方式吧,但我嫌麻烦,3个数的全排列就是6种,数据量比较小,应该不会超时,让你去求最多能堆多高,在上面的块严格小于下面的,(严格小于的意思就是下面的长宽都严格大于上面的,金字塔),我们把那个堆起来的金字塔倒过来,就变成了最长上涨升子序列的变形题了,很开心,模板一改就ac,我菜了,一下午
ac代码啊
#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <string>
#include <stack>
#include <queue>
#include <algorithm>
#include <map>
#define ll long long
#define inf 1e18+5

using namespace std;
int n,cas=0;
struct node{
int x,y,z;
}nn[3005];

bool cmp(node a,node b){
if(a.x==b.x)
return a.y < b.y;

return a.x < b.x;
}

int main(){

int x,y,z;
while(~scanf("%d",&n)&&n){
int cnt=0;
for(int i=1;i<=n;i++){
scanf("%d%d%d",&x,&y,&z);
nn[cnt].x=x,nn[cnt].y=y,nn[cnt++].z=z;
nn[cnt].x=x,nn[cnt].y=z,nn[cnt++].z=y;
nn[cnt].x=y,nn[cnt].y=x,nn[cnt++].z=z;
nn[cnt].x=y,nn[cnt].y=z,nn[cnt++].z=x;
nn[cnt].x=z,nn[cnt].y=x,nn[cnt++].z=y;
nn[cnt].x=z,nn[cnt].y=y,nn[cnt++].z=x;
}
//printf("*********%d\n",cnt);
sort(nn+1,nn+cnt,cmp);
int mmax=0;
int dp[2005];
memset(dp,0,sizeof(dp));
dp[1]=nn[1].z;
for(int i=2;i<cnt;i++){
mmax=0;
for(int j=1; j < i;j++){
if(nn[j].x < nn[i].x && nn[j].y < nn[i].y  ){
mmax=mmax>dp[j]?mmax:dp[j];
}
}
dp[i]=nn[i].z+mmax;
}
mmax=0;
for(int i=1;i<cnt;i++){
mmax=max(mmax,dp[i]);
}
printf("Case %d: maximum height = %d\n",++cas,mmax);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: