您的位置:首页 > 其它

nyoj - 43 24 Point game

2017-08-17 16:50 295 查看


24 Point game

时间限制:3000 ms  |  内存限制:65535 KB
难度:5

描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn't have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入
The input has multicases and each case contains one line

The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.

Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.

Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100

输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3


样例输出
Yes
No


每次从数组中选择两个进行4则运算,将得到的数重新存进数组里。由于有除法,所以要用double存,设置一个精度范围。直接暴力搜索可过。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n;
double a[105],m;
bool vis[105];
double cal(double num1,double num2,int op)
{
switch(op)
{
case 0: return num1+num2;
case 1: return num1-num2;
case 2: return num1*num2;
case 3: return num1/num2;
}
}
int eq(double a,double b)
{
if(a-b>=-(1e-6) && a-b<=1e-6)
return 1;
return 0;
}
int check()
{
for(int i=0;i<n;i++)
{
if(!vis[i])
{
if(eq(a[i],m))
return 1;
}
}
return 0;
}
int dfs(int step)
{
if(step==n-1)
{
if(check())
return 1;
return 0;
}
for(int i=0;i<n;i++)
{
if(vis[i])
continue;
for(int j=0;j<n;j++)
{
if(vis[j] || i==j)
continue;
vis[j]=1;
double last=a[i];
for(int k=0;k<4;k++)
{
double now=cal(a[i],a[j],k);
a[i]=now;
if(dfs(step+1))
return 1;
a[i]=last;
}
vis[j]=0;
}
}
return 0;
}
int main()
{
int cas;
scanf("%d",&cas);
while(cas--)
{
memset(vis,0,sizeof vis);
scanf("%d%lf",&n,&m);
for(int i=0;i<n;i++)
scanf("%lf",&a[i]);
if(dfs(0))
printf("Yes\n");
else
printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  nyoj - 43 24 Point game