您的位置:首页 > 其它

poj_1611_直接模拟

2017-08-17 16:45 274 查看
The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4

2 1 2

5 10 13 11 12 14

2 0 1

2 99 2

200 2

1 5

5 1 2 3 4 5

1 0

0 0

Sample Output

4

1

1

题意:

非典会传播,给你n,m代表总共有n个人,m个组,在同一组的人如果有人被怀疑得非典,整组都会被怀疑,求被怀疑的人数,非典的起点是0;

思路:

一旦有人被怀疑,就把这组,放到一个a组,最a数组中不同的人数就是ans

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=9999;
int num

,a[9999999];
int main()
{
int n,m,i,j;
while(cin>>n>>m&&(n+m))
{
map<int,int>q;
q.clear();
int t,pos=-1,k=0;
for(i=0; i<m; i++)
{
cin>>t;
num[i][0]=t;
for(j=1;j<=t;j++)
{
scanf("%d",&num[i][j]);
if(num[i][j]==0)
{
pos=i;
}
}
if(pos!=-1)
{
q[pos]=1;
for(j=1;j<=t;j++)
a[k++]=num[i][j];
pos=-1;
}
}
if(pos==-1&&k==0)
{
puts("1");
continue;
}
for(i=0;i<k;i++)//遍历a数组
{
for(j=0;j<m;j++)//遍历每一行
{
if(!q[j])//改行未使用
{
for(int jj=1;jj<=num[j][0];jj++)//遍历该行
{
if(num[j][jj]==a[i])//存在嫌疑人
{
for(int jjj=1;jjj<=num[j][0];jjj++)//a数组添加嫌疑人
{
a[k++]=num[j][jjj];
}
q[j]=1;
break;
}
}
}
}
}
sort(a,a+k);
int ans=0;
//puts("");
for(i=0;i<k-1;i++)
{
if(a[i]!=a[i+1])
ans++;
}
cout<<ans+1<<endl;
}
return 0;
}
/*
a
s
d
f
a
s
s
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj acm