您的位置:首页 > 其它

POJ - 1094 Sorting It All Out

2017-08-17 10:12 405 查看
Sorting It All Out

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35720 Accepted: 12569
Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will
give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of
the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character
"<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 

Sorted sequence cannot be determined. 

Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

Source

East Central North America 2001
nyoj上也有这道题,但是数据比较水。

拓扑排序。每输入一行都要进行拓扑排序。需要判断是否存在环,是否已经排序成功。

判定环:利用Kahn算法进行删点后,如果还存在入度大于0的点,则存在环。

判定排序成功:如果每次只能删一个点,且没有环,则排序成功。

如果有环,或者排序成功,就不需要继续拓扑排序了。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
int n,m,in[30],buf[30];
vector<int> vec[30];
int topo()
{
int degree[30],ok=1,num=0,cnt=0;
memcpy(degree,in,sizeof in);
queue<int> q;
for(int i=0;i<n;i++)
{
if(degree[i]==0)
{
cnt++;
q.push(i);
}
if(cnt>1)
ok=0;
}
while(!q.empty())
{
int top=q.front(); q.pop();
buf[num++]=top;
cnt=0;
for(int i=0;i<vec[top].size();i++)
{
int now=vec[top][i];
degree[now]--;
if(!degree[now])
{
cnt++;
q.push(now);
}
}
if(cnt>1)//未完成
ok=0;
}
for(int i=0;i<n;i++)
if(degree[i])
return -1;//有环
return ok;
}
int main()
{
char op[5];
while(scanf("%d%d",&n,&m) && n+m)
{
int flag=0;
for(int i=0;i<n;i++)
vec[i].clear();
memset(in,0,sizeof in);
for(int i=1;i<=m;i++)
{
scanf("%s",op);
in[op[2]-'A']++;
vec[op[0]-'A'].push_back(op[2]-'A');
if(flag==1 || flag==-1)
continue;
flag=topo();
if(flag==1)
{
printf("Sorted sequence determined after %d relations: ",i);
for(int i=0;i<n;i++)
printf("%c",buf[i]+'A');
printf(".\n");
}
if(flag==-1)
printf("Inconsistency found after %d relations.\n",i);
}
if(flag==0)
printf("Sorted sequence cannot be determined.\n");
}
return 0;
}
/*
6 5
A<D
B<C
A<B
D<E
C<D

6 6
A<D
B<C
E<F
B<A
D<E
A<B

6 6
D<E
B<F
A<D
F<C
A<F
E<B

3 3
A<B
B<C
C<A

4 6
A<B
A<C
B<C
C<D
B<D
A<B

3 2
A<B
B<A

2 2
A<B
B<A

26 1
A<Z

0 0
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息