您的位置:首页 > 其它

hdu 1058 humble number

2017-08-16 19:53 316 查看
Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying “The nth humble number is number.”. Depending on the value of n, the correct suffix “st”, “nd”, “rd”, or “th” for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1

2

3

4

11

12

13

21

22

23

100

1000

5842

0

Sample Output

The 1st humble number is 1.

The 2nd humble number is 2.

The 3rd humble number is 3.

The 4th humble number is 4.

The 11th humble number is 12.

The 12th humble number is 14.

The 13th humble number is 15.

The 21st humble number is 28.

The 22nd humble number is 30.

The 23rd humble number is 32.

The 100th humble number is 450.

The 1000th humble number is 385875.

The 5842nd humble number is 2000000000.

题解:

预处理出所有humber number;

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
typedef long long LL;
const LL maxn = 2000000000+20;
LL a[6000];
int k=1;
void init()
{
LL i,j,z,c;
for(i=1;i<maxn;i*=2)
for(j=1;j*i<maxn;j*=3)
for(z=1;i*j*z<maxn;z*=5)
for(c=1;i*j*z*c<maxn;c*=7)
{
a[k++]=i*j*z*c;
}
}

int main()
{
init();
sort(a+1,a+k);
LL n;
while(cin>>n&&n)
{
if(11<=n%100&&n%100<=13)
{
printf("The %dth humble number is ",n);
cout<<a
<<"."<<endl;
}
else if(n%10==1)
{
printf("The %dst humble number is ",n);
cout<<a
<<"."<<endl;
}
else if(n%10==2)
{
printf("The %dnd humble number is ",n);
cout<<a
<<"."<<endl;
}
else if(n%10==3)
{
printf("The %drd humble number is ",n);
cout<<a
<<"."<<endl;
}
else
{
printf("The %dth humble number is ",n);
cout<<a
<<"."<<endl;
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: