您的位置:首页 > 编程语言 > Go语言

hdu 5546 Ancient Go(dfs)

2017-08-16 19:11 344 查看


Ancient Go

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)

Total Submission(s): 2546    Accepted Submission(s): 798


Problem Description

Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

⋅The
game is played on a 8×8 cell
board, the chess can be put on the intersection of the board lines, so there are 9×9 different
positions to put the chess.
⋅Yu
Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
⋅The
chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, this component dies and will be removed from the game board.
⋅When
one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove the dead components.

One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and would like to know whether Yu Zhou has a move to kill at least one of Su Lu's
chess.

 

Input

The first line of the input gives the number of test cases, T(1≤T≤100). T test
cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. ′.′ represents
an empty cell. ′x′ represents
a cell with black chess which owned by Yu Zhou. ′o′ represents
a cell with white chess which owned by Su Lu.

 

Output

For each test case, output one line containing Case #x: y, where x is
the test case number (starting from 1) and y is Can
kill in one move!!!
 if Yu Zhou has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.

 

Sample Input

2

.......xo
.........
.........
..x......
.xox....x
.o.o...xo
..o......
.....xxxo
....xooo.

......ox.
.......o.
...o.....
..o.o....
...o.....
.........
.......o.
...x.....
........o

 

Sample Output

Case #1: Can kill in one move!!!
Case #2: Can not kill in one move!!!
Hint
In the first test case, Yu Zhou has 4 different ways to kill Su Lu's component.

In the second test case, there is no way to kill Su Lu's component.

/// Ancient Go dfs
#include<bits/stdc++.h>
using namespace std;
#define cle(n) memset(n,0,sizeof(n))
int vis[25][25],sum,cnt=0,T,flag;
char s[25][25];
int dx[]={0,0,-1,1};
int dy[]={1,-1,0,0};

int check(int x,int y) ///判断是否越界,该点是否不能是x
{
if(x>=0&&y>=0&&x<9&&y<9&&!vis[x][y]&&s[x][y]!='x')return 1;
return 0;
}

void dfs(int x,int y)
{
vis[x][y]=1; ///将该点标记我访问过
for(int i=0;i<4;i++){ ///访问四个方向
int nx,ny;
nx=x+dx[i];
ny=y+dy[i];
if(check(nx,ny)){
if(s[nx][ny]=='.'){sum+=1; vis[nx][ny]=1;} ///如果该点是 "." 则填充 o 棋子,填充一个则sum+1,当最终结果sum==1则可以得出flag=1
else dfs(nx,ny);
}
}
}
int main()
{
cin>>T;
while(T--)
{
cle(vis); flag=0;
for(int i=0;i<9;i++)cin>>s[i];
for(int i=0;i<9;i++){
for(int j=0;j<9;j++){
if(s[i][j]=='o'&&!vis[i][j]){
cle(vis); sum=0; dfs(i,j);
if(sum==1){flag=1;i=10;break;}
}
}
}
if(flag)printf("Case #%d: Can kill in one move!!!\n",++cnt);
else printf("Case #%d: Can not kill in one move!!!\n",++cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: