您的位置:首页 > 其它

HDU 1312 Red and Black DFS深搜

2017-08-16 17:54 120 查看
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

InputThe input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

OutputFor each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output
45
59
6
13


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int vis[25][25],ans,w,h;
char s[25][25];
int fx[4]={0,0,-1,1},fy[4]={-1,1,0,0};
void dfs(int x,int y) //参数:要搜到点的坐标 返回值:
{
// printf ("===%d %d===\n",x,y);
vis[x][y]=1;
for(int i=0;i<4;i++)
{
int xx=x+fx[i],yy=fy[i]+y;
if(xx>=0&&yy>=0&&xx<h&&yy<w&&!vis[xx][yy]&&s[xx][yy]=='.')
{
ans++;
dfs(xx,yy);
}
}
}
int main()
{
while(scanf("%d%d",&w,&h),w&&h)
{
getchar();
memset(vis,0,sizeof(vis));
for(int i=0;i<h;i++)
{
// scanf ("%s",s[i]);
for(int j=0;j<w;j++)
{
scanf("%c",&s[i][j]);
}
getchar();
}
ans=1;
for(int i=0;i<h;i++)
{
bool flag = false;
for(int j=0;j<w;j++)
{
if(s[i][j]=='@')
{
dfs(i,j);
flag = true;
break;
}
}
if (flag)
break;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: