您的位置:首页 > 大数据 > 人工智能

2017多校训练Contest2: 1001 Captain is coding hdu6045

2017-08-16 15:42 330 查看
Problem Description

Derek and Alfia are
good friends.Derek is
Chinese,and Alfia is
Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice
questions and each question is followed by three choices marked “A”
“B”
and “C”.Each
question has only one correct answer and each question is worth 1 point.It
means that if your answer for this question is right,you can get 1point.The
total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the
total score of him and Alfia.Then Alfiawill
ask Derek the
total score of her and he will tell her: “My total score is X,your
total score is Y.”But Derek is
naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you
should judge whether Derek is
lying.If there exists a set of standard answer satisfy the total score that Dereksaid,you
can consider he is not lying,otherwise he is lying.

 

Input

The first line consists of an integer T,represents
the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the
meaning is mentioned above.

The second line consists of N characters,each
character is “A”
“B”
or “C”,which
represents the answer of Derek for
each question.

The third line consists of N characters,the
same form as the second line,which represents the answer of Alfia for
each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000

 

Output

For each test case,the output will be only a line.

Please print “Lying”
if you can make sure that Derek is
lying,otherwise please print “Not lying”.

 

Sample Input

2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

 

Sample Output

Not lying
Lying

统计答案相同的个数s1和不同的个数s2,先使用答案相同的题目再使用不同的题目。不妨设x>y

那么如果s1>=y,只需要让相同的对y题,然后不同的补足x

否则的话使相同的全对,不同的补足x和y剩下的即可

#include<queue>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<cassert>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int T;
scanf("%d",&T);
while(T>0)
{
T--;
int n,x,y;
scanf("%d%d%d",&n,&x,&y);
if(x<y)
{
int t=x;
x=y;
y=t;
}
string x1,x2;
cin>>x1>>x2;
int i;
int s1=0,s2=0;
for(i=0;i<=n-1;i++)
{
if(x1[i]==x2[i])
s1++;
else
s2++;
}
bool flag;
if(s1>=y)
{
x-=y;
if(x<=s2)
flag=true;
else
flag=false;
}
else
{
x-=s1;
y-=s1;
if(x+y<=s2)
flag=true;
else
flag=false;
}
if(flag)
printf("Not lying\n");
else
printf("Lying\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  贪心 模拟