您的位置:首页 > 其它

(HDU - 1241)Oil Deposits

2017-08-16 14:53 344 查看

(HDU - 1241)Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 33422 Accepted Submission(s): 19409

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*’, representing the absence of oil, or ‘@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1

*

3 5

*@*@*

**@**

*@*@*

1 8

@@****@*

5 5

****@

*@@*@

*@**@

@@@*@

@@**@

0 0

Sample Output

0

1

2

2

题目大意:在m行n列的矩形块中,符号@代表有油田,符号*代表没有油。如果两块油田彼此相邻就说这两块油田属于同一油田块(所谓相邻就是上下,左右,对角线相邻)。问矩形块中有多少油田块。

思路:典型dfs,不用回溯。

#include<cstdio>
using namespace std;

const int maxn=105;
char a[maxn][maxn];
const int dir[8][2]={{1,0},{1,1},{0,1},{-1,1},{-1,0},{-1,-1},{0,-1},{1,-1}};
int m,n;

bool check(int x,int y)
{
return (x>=0&&x<m&&y>=0&&y<n);
}

void dfs(int x,int y)
{
a[x][y]='*';
for(int i=0;i<8;i++)
{
int tmpx=x+dir[i][0];
int tmpy=y+dir[i][1];
if(check(tmpx,tmpy)&&a[tmpx][tmpy]=='@')
dfs(tmpx,tmpy);
}
}

int main()
{
while(scanf("%d%d",&m,&n)!=EOF&&(m||n))
{
for(int i=0;i<m;i++) scanf("%s",a[i]);
int ans=0;
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
{
if(a[i][j]=='@')
{
ans++;
dfs(i,j);
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: