您的位置:首页 > 其它

【 poj 1961 】Period 【KMP 求所有前缀的循环节】

2017-08-16 11:19 591 查看
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the

number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3

aaa

12

aabaabaabaab

0

Sample Output

Test case #1

2 2

3 3

Test case #2

2 2

6 2

9 3

12 4

题意 就是要求 一个字符串S,其所有的前缀的循环节(这里循环节必须大于2,也就是说不能够是自己和自己循环节那种)

也就是这道题的升级版

代码

#include<cstdio>
#include<cstring>
using namespace std ;
typedef long long LL ;

const int MAXN = 1000000+10 ;
const int MAXM = 1e5 ;
const int mod  =10007 ;

int n;
char str[MAXN];
int nexts[MAXN];
void getn(){
int i,j;i=j=0;
nexts[0]=-1;j=-1;
while(i<n){
if(j==-1||str[i]==str[j]) nexts[++i]=++j;
else j=nexts[j];
}
}

int main(){
int ncase=1;
while(scanf("%d",&n)&&n){
scanf("%s",str);
printf("Test case #%d\n",ncase++);
getn();
for(int i=2;i<=n;i++){
if(i%(i-nexts[i])||!nexts[i]) continue;
printf("%d %d\n",i,i/(i-nexts[i]));
}
puts("");
}
return  0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: