您的位置:首页 > 其它

D - Count the string

2017-08-16 11:08 204 查看
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example: 

s: "abab" 

The prefixes are: "a", "ab", "aba", "abab" 

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6. 

The answer may be very large, so output the answer mod 10007. 

InputThe first line is a single integer T, indicating the number of test cases. 

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters. 

OutputFor each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
Sample Input
1
4
abab


Sample Output
6


题意:输出每一个前缀和他本身在字符串中出现次数总和。。。

思路:看的别人博客的结论,,一开始想每一个前缀用一下KMP,但想想会超时。。。。最后才知道是用next数组,,,

假设用dp[i]表示到第i个字符为止出现的前缀个数,那么由next数组我们知道next[i]的值表示以第next[i]个字符为结尾的出现的字符个数加他本身。。这样就可以用动态规划解出答案,状态转移方程为dp[i]=dp[next[i]]+1....

下面附上代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=100005;
const int mod=256;
int Next
,dp
;
char s
;
void Getnext(char *t,int l)
{
int i=0,j;
Next[i]=-1,j=-1;
while(i<l)
{
if(j==-1||t[i]==t[j])
{
Next[++i]=++j;
}
else
j=Next[j];
}
}
int main()
{
while(~scanf("%s",s))
{
int n=strlen(s);
Getnext(s,n);
memset(dp,0,sizeof(dp));
int sum=0;
for(int i=1;i<=n;i++)
{
dp[i]=dp[Next[i]]+1;
sum=(sum+dp[i])%mod;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: