您的位置:首页 > 其它

A water problem(大数取模)

2017-08-16 08:41 267 查看
A water problem

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 3124 Accepted Submission(s): 1126

Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output

For the i-th test case, output Case #i: , then output “YES” or “NO” for the answer.

Sample Input

10001

0

333

Sample Output

Case #1: YES

Case #2: YES

Case #3: NO

一定要注意,题目给的是N的长度,一看就知道使用字符串~

题意是看看这个数能不能同时被137和73整除,他俩的最小公倍数是10001,所以取模10001就可以了!

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
char n[10000001];
int main()
{
int t = 1;
while(~scanf("%s", n))
{
int len = strlen(n);
int v = 0;
for(int i=0;i<len;i++)//字符串转化的取模运算
{
v = (v*10 + n[i]-'0') % 10001;
}
if(v==0)
cout<<"Case #"<<t<<": "<<"YES"<<endl;
else
cout<<"Case #"<<t<<": "<<"NO"<<endl;
t++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  大数取模