您的位置:首页 > 其它

HDU 2602 Bone Collector(01背包裸题)

2017-08-16 06:35 399 查看
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”.
This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there
are a lot of bones , obviously , different bone has different value and different volume,
now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?




Input:

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer
 N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag.
 And the second line contain N integers representing the value of each bone. The third line
contain N integers representing the volume of each bone.
Output:
One integer per line representing the maximum of the total value (this number will be less than 2 31).Sample Input:
1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output:
14

思路:
动规01 背包模板题,真的是裸的不能再裸了。

代码:

#include<stdio.h>
#include<iostream>
#include<queue>
#include<cstring>
#include<cmath>

using namespace std;

#define MAXN 1005

int N,V;
int vol[MAXN],val[MAXN];
int dp[MAXN];

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(dp,0,sizeof(dp));
scanf("%d %d",&N,&V);
for(int i=0 ; i<N ; i++)
{
scanf("%d",&val[i]);
}
for(int i=0 ; i<N ; i++)
{
scanf("%d",&vol[i]);
}
for(int i=0 ; i<N ; i++)
{
for(int j=V ; j>=vol[i] ; j--)
{
dp[j] = max(dp[j],dp[j-vol[i]]+val[i]);
}
}
printf("%d\n",dp[V]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: