您的位置:首页 > 其它

【poj 3070】Fibonacci

2017-08-15 20:15 232 查看
D - Fibonacci
Time Limit:1000MS     Memory Limit:65536KB     64bit
IO Format:
%I64d & %I64u

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of
the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is


.
Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input
0
9
999999999
1000000000
-1

Sample Output
0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

Source

代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
#define LL long long
#define Mod 10000
#define CLR(a,b) memset(a,b,sizeof(a))
using namespace std;
struct Mat
{
int a[4][4];
int h,w;
}pr,ans;
void init()
{
ans.a[2][1]=ans.a[1][2]=0;  //初始化过渡矩阵
ans.h=ans.w=2;
for(int i=1;i<=2;i++)
ans.a[i][i]=1;
pr.a[1][1]=pr.a[1][2]=pr.a[2][1]=1; //初始化单位矩阵
pr.a[2][2]=0;
pr.h=pr.w=2;
}
Mat Mat_Mul(Mat x,Mat y)  //矩阵相乘
{
Mat t;
CLR(t.a,0);
t.h=x.h;
t.w=y.w;
for(int i=1;i<=x.h;i++)
{
for(int j=1;j<=x.w;j++)
{
if(x.a[i][j]==0) continue;
for(int k=1;k<=y.w;k++)
t.a[i][k]=(t.a[i][k]+x.a[i][j]*y.a[j][k]%Mod)%Mod;
}
}
return t;
}
void Mat_mod(int n)  //矩阵快速幂
{
while(n)
{
if(n&1)
ans=Mat_Mul(pr,ans);
pr=Mat_Mul(pr,pr);
n>>=1;
}
}
int main()
{
int n;
while(~scanf("%d",&n)&&n!=-1)
{
init();
Mat_mod(n);
printf("%d\n",ans.a[1][2]%Mod);
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: