您的位置:首页 > 其它

hdu-6124-Euler theorem(多校训练)

2017-08-15 20:13 363 查看

Euler theorem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)

Total Submission(s): 120    Accepted Submission(s): 103


Problem Description

HazelFan is given two positive integers a,b,
and he wants to calculate amodb.
But now he forgets the value of b and
only remember the value of a,
please tell him the number of different possible results.
 

Input

The first line contains a positive integer T(1≤T≤5),
denoting the number of test cases.

For each test case:

A single line contains a positive integer a(1≤a≤109).
 

Output

For each test case:

A single line contains a nonnegative integer, denoting the answer.

 

Sample Input

2
1
3

 

Sample Output

2


题意:求a对任何数取余余数有都少种

比赛时我们就直暴力输出结果找规律就过了,,,规律:奇数/2  +2,偶数 / 2+1,

code:
#include<bits/stdc++.h>
using namespace std;
int main()
{
int T;
scanf("%d",&T);
while(T--){
int a;
scanf("%d",&a);
printf("%d\n",(a-1)/2+2);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: