您的位置:首页 > 其它

Zipper(动态规划)

2017-08-15 18:13 316 查看
点击打开链接

描述
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat

String B: tree

String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat

String B: tree

String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

输入
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two
strings will have lengths between 1 and 200 characters, inclusive.

输出
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

样例输入
3
cat tree tcraete
cat tree catrtee
cat tree cttaree


样例输出
Data set 1: yes
Data set 2: yes
Data set 3: no


来源
Pacific Northwest 2004

花了好长时间终于用动态规划的方法把样例输入的结果给弄对,但是提交的时候却是WA,后来看了别人的代码发现好多都是用记忆化搜索来做的

AC代码


源代码

#include <stdio.h>
#include <string.h>

int main()
{
int  i, j, k, t;
int  L1, L2, ok[202][202];
char str1[201], str2[201], str3[402];
/**********************
ok[i][j]为真时表示str1的前i个字符可以和str2的前j个字符
组成str3的前i+j个字符。为假时 表示不能。
***********************/

scanf("%d", &t);
for (i=1; i<=t; i++)
{
scanf("%s %s %s", str1, str2, str3);
memset(ok, 0, sizeof(ok));
L1 = strlen(str1);
L2 = strlen(str2);

ok[0][0] = 1;
for (j=1; j<=L1; j++)
{
if (ok[j-1][0] == 1 && str1[j-1] == str3[j-1])
ok[j][0] = 1;
else
break;
}
for (j=1; j<=L2; j++)
{
if (ok[0][j-1] == 1 && str2[j-1] == str3[j-1])
ok[0][j] = 1;
else
break;
}
for (j=1; j<=L1; j++)
{
for (k=1; k<=L2; k++)
{
if (ok[j-1][k]==1 && str1[j-1]==str3[j+k-1] || ok[j][k-1]==1 && str2[k-1]==str3[j+k-1])
ok[j][k] = 1;
}
}
if (ok[L1][L2] == 1)
printf("Data set %d: yes\n", i);
else
printf("Data set %d: no\n", i);
}
}


WA代码


源代码

#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
#include<iostream>

using namespace std;
char strr1[1010];
char strr2[1010];
char strr3[1010];
int maxLen[1010][1010];
int main()
{
int n;
scanf("%d",&n);
for(int w=1; w<=n; w++)
{
scanf("%s %s %s",&strr1,&strr2,&strr3);
int length1=strlen(strr1);
int length2=strlen(strr2);
int length3=strlen(strr3);
int nTmp;
//		int i,j,k;
memset(maxLen,0,sizeof(maxLen));
for(int i=0; i<=length1; i++)
{
maxLen[i][0
c91e
]=0;
}
for(int k=0; k<=length3; k++)
{
maxLen[0][k]=0;
}
for(int i=1; i<=length1; i++)
{
for(int k=1; k<=length3; k++)
{
if(strr1[i-1]==strr3[k-1])
maxLen[i][k]=maxLen[i-1][k-1]+1;
else
maxLen[i][k]=max(maxLen[i-1][k],maxLen[i][k-1]);
}
}
if(maxLen[length1][length3]==length1)
{
memset(maxLen,0,sizeof(maxLen));

for(int j=0; j<length2; j++)
{
maxLen[j][0]=0;
}

for(int k=0; k<length3; k++)
{
maxLen[0][k]=0;
}

for(int j=1; j<=length2; j++)
{
for(int k=1; k<=length3; k++)
{
if(strr2[j-1]==strr3[k-1])
maxLen[j][k]=maxLen[j-1][k-1]+1;
else
maxLen[j][k]=max(maxLen[j-1][k],maxLen[j][k-1]);
}
}
if(maxLen[length2][length3]==length2)
printf("Data set %d: yes\n",w);
else
printf("Data set %d: no\n",w);

}
else
printf("Data set %d: no\n",w);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: