您的位置:首页 > 编程语言 > Go语言

lightoj 1259 Goldbach`s Conjecture

2017-08-15 16:11 106 查看
解题思路:按照常规暴力的话,结果肯定是Memory  Limit,所以这道题可以用素数筛先把素数找出来,记录在一个数组里面,等用的时候直接可以用。见代码吧!!!

这道题还有一个需要注意到,开数组的时候用bool型,因为bool型占一个字节,而int占四个字节

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input
Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input
2

6

4

Sample Output
Case 1: 1

Case 2: 1

Hint
1.      An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, ...

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
bool vis[10000005];
vector<int> v;

void get_prime()
{
memset(vis,false,sizeof(vis));
vis[1]=true;
for(int i = 2; i<=10000000; i++)
{
int t=10000000/i;
for(int j=2;j<=t;j++)
vis[i*j]=true;
}
for(int i=2;i<=10000000;i++)
if(!vis[i])
v.push_back(i);
}

int main()
{
get_prime();
int T,t=1;
scanf("%d",&T);
while(T--)
{
int n,ans=0;
scanf("%d",&n);
for(int i=0;v[i]<=n/2;i++)
{
if(!vis[n-v[i]])
ans++;
}
printf("Case %d: %d\n",t++,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数论