您的位置:首页 > 其它

hdu 6130 Kolakoski(多校联赛)

2017-08-15 16:05 344 查看


Kolakoski

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

This is Kolakosiki sequence: 1,2,2,1,1,2,1,2,2,1,2,2,1,1,2,1,1,2,2,1…….
This sequence consists of 1 and 2,
and its first term equals 1.
Besides, if you see adjacent and equal terms as one group, you will get 1,22,11,2,1,22,1,22,11,2,11,22,1…….
Count number of terms in every group, you will get the sequence itself. Now, the sequence can be uniquely determined. Please tell HazelFan its nth
element.

 

Input

The first line contains a positive integer T(1≤T≤5),
denoting the number of test cases.

For each test case:

A single line contains a positive integer n(1≤n≤107).

 

Output

For each test case:

A single line contains a nonnegative integer, denoting the answer.

 

Sample Input

2
1
2

 

Sample Output

1
2

水题一道 但是学到了一个新的高深而难懂数列

ac代码:

#include<bits/stdc++.h>
#define inf 10000000
using namespace std;
int a[10000000+5];
int ke()
{
a[1]=1,a[2]=2,a[3]=2;
int sum=3;
for(int i=3;i<=inf;i++)
{
if(a[i]==2)
{
if(a[sum]==2)
{
a[sum+1]=a[sum+2]=1;
}
if(a[sum]==1)
{
a[sum+1]=a[sum+2]=2;
}
}
if(a[i]==1)
{
if(a[sum]==2)
{
a[sum+1]=1;
}
if(a[sum]==1)
{
a[sum+1]=2;
}
}
sum=sum+a[i];
if(sum>=inf)
break;
}
}
int main()
{
ke();
int t,n;
while(scanf("%d",&t)!=EOF)
{
while(t--)
{
scanf("%d",&n);
printf("%d\n",a
);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: