您的位置:首页 > 其它

hdu6124--Euler theorem

2017-08-15 13:54 295 查看

Problem Description

HazelFan is given two positive integers
a,b,
and he wants to calculate amodb.
But now he forgets the value of b
and only remember the value of a,
please tell him the number of different possible results.

Input

The first line contains a positive integer
T(1≤T≤5),
denoting the number of test cases.

For each test case:

A single line contains a positive integer a(1≤a≤109).
 

Output

For each test case:

A single line contains a nonnegative integer, denoting the answer.

Sample Input

2
1
3

[align=left]
[/align]

Sample Output

2
3

 

分析

以为是欧拉,各种打表找规律
mmp写出前10个立刻出结果
就是(a+1)/2+1呵呵


代码

#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int a;
scanf("%d",&a);
cout<<(a+1)/2+1<<endl;
}
return 0;
}

链接

[align=left]
[/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: