您的位置:首页 > 大数据 > 人工智能

light oj-1282 Leading and Trailing

2017-08-15 13:50 411 查看
You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant).
You can assume that the input is given such that nk contains at least six digits.

//你可以假设输入的数的结果最小有6位数

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

题意: 求n^k的前三位和后三位

后三位直接用幂运算就可以求出,但是要注意:1.当后三为全部为0的特殊情况,所以用%3d输出

2.在输出前三位之前要判断前三位是否大于100

前三位 :

    1. n=10^a

    2. n^k=10^(a*k)

    3. a=log10(n)

    4. log10(n^k)=k * log10(n)

设z为a的整数部分,x为a的小数部分

求10的a次方 ==> 10^z+10^x

所以求出x ==> fmod(k*(log10(n),1)

要求前三位数sum ; sum=pow(10,x+2)

10^2=100 10^3=1000

fmod函数:

1.计算x/y的余数 2.还可以取某个数小数点后的部分

eg2: fmod(f,(int)f) 即可取得小数点后的部分

头文件:  #include<math.h>

#include<stdio.h>
#include<string.h>
#include<math.h>
#define ll long long

ll mod_pow(ll x,ll n, ll mod)
{
if(n == 0)
return 1;

ll res = mod_pow(x*x%mod,n/2,mod);

if(n&1)
res = res * x % mod;

return res;
}

int main()
{
ll n,k;
int t,s=1;
scanf("%d",&t);

while(t--)
{
scanf("%lld %lld",&n,&k);

int st=pow(10,fmod(k*(log10(n)),1)+2);
while(st<100)
{
st*=10;
}
int ed=(int)mod_pow(n,k,1000);
printf("Case %d: %d %03d\n",s++,st,ed);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: