您的位置:首页 > 其它

Euler theorem(水)

2017-08-15 12:32 120 查看


Euler theorem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

HazelFan is given two positive integers a,b,
and he wants to calculate amodb.
But now he forgets the value of b and
only remember the value of a,
please tell him the number of different possible results.

 

Input

The first line contains a positive integer T(1≤T≤5),
denoting the number of test cases.

For each test case:

A single line contains a positive integer a(1≤a≤109).

 

Output

For each test case:

A single line contains a nonnegative integer, denoting the answer.

 

Sample Input

2
1
3

 

Sample Output

2
3思路找规律

#include<cstdio>
#include<iostream>
#include<math.h>
using namespace std;
int a,b,t;
int main()
{
scanf("%d",&t);
while(t--)
{
scanf("%d",&a);
int ans;
if(a%2==0)
printf("%d\n",a/2+1);
else
printf("%d\n",a/2+2);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: