您的位置:首页 > 其它

HDU - 3038 How Many Answers Are Wrong(带权并查集)

2017-08-15 10:23 441 查看
Problem Description

TT and FF are … friends. Uh… very very good friends -__-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5

1 10 100

7 10 28

1 3 32

4 6 41

6 6 1

Sample Output

1

题目大意: 给你m个区间和区间内数字加和, 问你有几个是与前面矛盾的。

大体思路:每输入一个区间, 查询根节点, 根节点相同则比较描述的区间和是否和已有的矛盾,根节点不相同则合并,并更新val数组权值。典型带权并查集问题, 当模板用。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 200100
using namespace std;
int pre
;
int val
;//val[i]记录i到下一节点边权
int _find(int x);//查询根节点并更新边权
int main()
{

int n, m;
while(scanf("%d%d", &n, &m) != EOF)
{
for(int i = 0; i <= n; i++)//初始化
{
pre[i] = i;
val[i] = 0;
}
int ans = 0;
for(int i = 0; i < m; i++)
{
int u, v, w;
scanf("%d%d%d", &u, &v, &w);
u--;
int fu = _find(u);//寻找根节点
int fv = _find(v);
if(fu == fv)
{
if(val[v] - val[u] != w)//根节点相同判断是否和已有的区间和矛盾
{
ans++;
}
}
else
{
pre[fv] = fu;//合并操作
val[fv] = w - val[v] + val[u];//原本v -> u, u -> fu, v -> fv, 边权分别为val[u] val[v] w , 更新后fv -> fu,边权为w - val[v] + val[u]
}

}
printf("%d\n", ans);
}
return 0;
}
int _find(int x)
{
if(pre[x] == x)
{
return x;
}
int p = _find(pre[x]);
val[x] += val[pre[x]];
pre[x] = p;
return p;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  带权并查集