您的位置:首页 > 大数据 > 人工智能

HDU 1702-ACboy needs your help again!

2017-08-15 09:52 344 查看


ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 8632    Accepted Submission(s): 4328

题目链接:点击打开链接

Problem Description

ACboy was kidnapped!! 

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

 

Input

The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.

 

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

Sample Input

4

4 FIFO

IN 1

IN 2

OUT

OUT

4 FILO

IN 1

IN 2

OUT

OUT

5 FIFO

IN 1

IN 2

OUT

OUT

OUT

5 FILO

IN 1

IN 2

OUT

IN 3

OUT

 

Sample Output

1

2

2

1

1

2

None

2

3

简单的栈和队列的练习题,在这里特别注意的是将栈和队列定义在 if 里面,也可以再用时先清空,避免上一轮残留的元素会对新一轮的操作有影响

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
#include<string>
using namespace std;

int main()
{
int t,n,a;
string s,h;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
cin>>s;
if(s=="FIFO")
{
queue<int>p;
while(n--)
{
cin>>h;
if(h=="IN")
{
scanf("%d",&a);
p.push(a);
}
if(h=="OUT")
{
if(p.empty())
printf("None\n");
else
{
printf("%d\n",p.front());
p.pop();
}
}
}
}
if(s=="FILO")
{
stack<int>q;
while(n--)
{
cin>>h;
if(h=="IN")
{
scanf("%d",&a);
q.push(a);
}
if(h=="OUT")
{
if(q.empty())
printf("None\n");
else
{
printf("%d\n",q.top());
q.pop();
}
}
}
}
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: