您的位置:首页 > 编程语言 > Go语言

Goldbach`s Conjecture LightOJ 1259

2017-08-14 21:47 281 查看
题目链接


Goldbach`s Conjecture

Description

Goldbach's conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:

Every even integer, greater than 2, can be expressed as the sum of two primes [1].

Now your task is to check whether this conjecture holds for integers up to 107.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).

Output

For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where

1)      Both a and b are prime

2)      a + b = n

3)      a ≤ b

Sample Input

2

6

4

Sample Output

Case 1: 1

Case 2: 1

解题思路:这个题非常坑,题上显示数据范围(10^7),使用int数组标记筛选,内存超限,需要使用bool型数组,因为int型每个数字占四个字节,而bool型占一个字节。还有一点,需要把素数存入一个向量里面(用int 数组存,编译器会出现错误,不知道为什么?)。

#include <stdio.h>
#include <string.h>
#define maxn 10000000+1
#include <vector>
using namespace std;

bool num[maxn];
vector<int>Q;
int n;

void prime()
{
memset(num,false,sizeof(num));

for(int i=2; i<=maxn; i++)
{
if(num[i]==false)
{
for(int j=i+i; j<=maxn; j+=i)
num[j]=true;
}
}
Q.push_back(2);
for(int i=3; i<=maxn; i+=2)
if(num[i]==false)
Q.push_back(i);
}
int main()
{
int t,Case=1;
prime();
scanf("%d",&t);
while(t--)
{
int n,cont=0;
scanf("%d",&n);
for(int i=0; Q[i]<=n/2; i++)
{
if(num[n-Q[i]]==false)
cont++;
}
printf("Case %d: %d\n",Case++,cont);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: