您的位置:首页 > 其它

hdu 5510 Bazinga(KMP+剪枝)

2017-08-14 20:33 405 查看

Bazinga

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 4409    Accepted Submission(s): 1409


[align=left]Problem Description[/align]
Ladies and gentlemen, please sit up straight.
Don't tilt your head. I'm serious.



For n
given strings S1,S2,⋯,Sn,
labelled from 1
to n,
you should find the largest i (1≤i≤n)
such that there exists an integer j (1≤j<i)
and Sj
is not a substring of Si.

A substring of a string Si
is another string that occurs in
Si.
For example, ``ruiz" is a substring of ``ruizhang", and ``rzhang" is not a substring of ``ruizhang".
 

[align=left]Input[/align]
The first line contains an integer
t (1≤t≤50)
which is the number of test cases.

For each test case, the first line is the positive integer
n (1≤n≤500)
and in the following n
lines list are the strings S1,S2,⋯,Sn.

All strings are given in lower-case letters and strings are no longer than
2000
letters.
 

[align=left]Output[/align]
For each test case, output the largest label you get. If it does not exist, output
−1.
 

[align=left]Sample Input[/align]

4
5
ab
abc
zabc
abcd
zabcd
4
you
lovinyou
aboutlovinyou
allaboutlovinyou
5
de
def
abcd
abcde
abcdef
3
a
ba
ccc

 

[align=left]Sample Output[/align]

Case #1: 4
Case #2: -1
Case #3: 4
Case #4: 3

 

[align=left]Source[/align]
2015ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)
 

思路:这个题目肯定是要将每一个串与它前面的所有串都比较一次,看是不是它的子串。但这样暴力的解法是会超时的。那么就剪枝吧。

我们假设第i个串与第i+1个串匹配了,那么再往后,如果第i+1与第i+2个串也匹配了,那么第i个串一定也是与第i+2个串匹配的。有了这个想法后,我们可以把每次匹配成功的那个第i个串都附上匹配成功的标记,再以后的串只要和没有匹配成功的串进行匹配就行了。这样就减少时间

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_N 2005
using namespace std;
int ne[MAX_N];
char t[505][MAX_N];
int jud[505];
void makeNext(const char p[],int ne[])
{
int len=strlen(p);
ne[0]=0;
for(int i=1,k=0;i<len;i++)
{
while(k>0&&p[i]!=p[k]) k=ne[k-1];
if(p[i]==p[k]) k++;
ne[i]=k;
}
}
int kmp(const char t[],const char p[],int ne[])
{
int n=strlen(t),m=strlen(p);
makeNext(p,ne);
for(int i=0,k=0;i<n;i++)
{
while(k>0&&t[i]!=p[k]) k=ne[k-1];
if(t[i]==p[k]) k++;
if(k==m)
return 1;
}
return 0;
}
int main()
{
int c;
scanf("%d",&c);
for(int k=1;k<=c;k++)
{
int n,num=1;
scanf("%d",&n);
memset(jud,0,sizeof(jud));
for(int i=1;i<=n;i++)
scanf("%s",t[i]);
int flag=0;
for(int i=1;i<=n;i++)
{
for(int j=i-1;j>=1;j--)
{
if(jud[j]!=0)
continue;
else
{
if(kmp(t[i],t[j],ne))
jud[j]=1;//匹配成功的标记
else
{
num=i;
flag=1;//找到了这样的串
}
}
}
}
if(!flag)
printf("Case #%d: %d\n",k,-1);
else
printf("Case #%d: %d\n",k,num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: