您的位置:首页 > 产品设计 > UI/UE

HDU——T 1711 Number Sequence

2017-08-14 20:24 267 查看

http://acm.hdu.edu.cn/showproblem.php?pid=1711

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29129    Accepted Submission(s): 12254


Problem Description Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.  

 

Input The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].  

 

Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.  

 

Sample Input 2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1  

 

Sample Output 6 -1   模板练习题
#include <algorithm>
#include <cstdio>

using namespace std;

const int N(1000000+5);
const int M(10000+626);
int l1,l2,a
,b
,p
;

inline void Get_next()
{
for(int j=0,i=2;i<=l2;i++)
{
if(j>0&&b[i]!=b[j+1]) j=p[j];
if(b[i]==b[j+1]) j++;
p[i]=j;
}
}
inline void kmp()
{
for(int j=0,i=1;i<=l1;i++)
{
if(j>0&&a[i]!=b[j+1]) j=p[j];
if(a[i]==b[j+1]) j++;
if(j==l2)
{
printf("%d\n",i-j+1);
return ;
}
}
puts("-1");
}

int main()
{
int t;scanf("%d",&t);
for(;t--;)
{
scanf("%d%d",&l1,&l2);
for(int i=1;i<=l1;i++) scanf("%d",a+i);
for(int i=1;i<=l2;i++) scanf("%d",b+i);
Get_next();
kmp();
}
return 0;
}

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: