您的位置:首页 > 其它

B - Big Event in HDU(背包问题01背包)

2017-08-14 19:08 309 查看

B - Big Event in HDU

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of
the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.

Output For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.

Sample Input
2
10 1
20 1
3
10 1
20 2
30 1
-1

Sample Output
20 10
40 40


嗯我是转载来自http://blog.csdn.net/libin56842/article/details/9034667、

嗯.....刚开始也有点懵不是很理解  不过可以自己弄下数字来说

比如说

3

20 1

30 1

20 1

这样子的话总的是70 然后sum/2是35    只能放一个30的  也就是说利用01背包而言 第一个要么就是和第二个一样大 要么就是比第二个来的大sum-cost[sum/2]

嗯就是这样子     先求总和然后在平均一下仔细想想确实是 思路很不错不过不是我想的 嘿嘿 好好学习

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<math.h>
using namespace std;
int digit[100005];
int cost[100005];
int main()
{
int n;
while(scanf("%d",&n),n>0)
{
int sum=0;
int a ,b;
int k=1;
memset(digit,0,sizeof(digit));
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a,&b);
while(b--)
{
digit[k++]=a;
sum=sum+a;
}
}
memset(cost,0,sizeof(cost));
for(int i=1;i<k;i++)
{
for(int j=sum/2;j>=digit[i];j--)
{
cost[j]=max(cost[j],cost[j-digit[i]]+digit[i]);
}
}
printf("%d %d\n",sum-cost[sum/2],cost[sum/2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: