您的位置:首页 > 其它

C - Bone Collector(背包问题)(01背包)

2017-08-14 18:45 309 查看

C - Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



Input The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone. Output One integer per line representing the maximum of the total value (this number will be less than 2
31). Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14


嗯一道简单的01背包问题

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define maxn 1005
int over[maxn];
int volume[maxn];
int value[maxn];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m,i,j;
scanf("%d%d",&n,&m);
memset(value,0,sizeof(value));
memset(volume,0,sizeof(volume));
memset(over,0,sizeof(over));
for( i=1;i<=n;i++)
scanf("%d",&value[i]);
for( i=1;i<=n;i++)
scanf("%d",&volume[i]);
for(i=1;i<=n;i++)
{
for(j=m;j>=volume[i];j--)
{
over[j]=max(over[j],over[j-volume[i]]+value[i]);
}
}
printf("%d\n",over[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: