您的位置:首页 > 其它

hdu-1757-A Simple Math Problem(矩阵快速幂入门题)

2017-08-14 16:22 447 查看


A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5157    Accepted Submission(s): 3128


Problem Description

Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.

If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);

And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

 

Input

The problem contains mutiple test cases.Please process to the end of file.

In each case, there will be two lines.

In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )

In the second line , there are ten integers represent a0 ~ a9.

 

Output

For each case, output f(k) % m in one line.

 

Sample Input

10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0

 

Sample Output

45
104

题意:求下图公式的结果     这一题 还是个 递推关系式 的矩阵就非常的好推了  和之前的几乎一样  这里就不解释了



 

code:

#include<cstdio>
#include<cstring>
using namespace std;
const int N=10;
int n,mod;
int temp

;
int res

,a

;
void mul(int a[]
,int b[]
)
{
memset(temp,0,sizeof(temp));
for(int i=0;i<N;i++)
for(int j=0;j<N;j++)
for(int k=0;k<N;k++)
temp[i][j]=(temp[i][j]+a[i][k]*b[k][j]%mod)%mod;
for(int i=0;i<N;i++)
for(int j=0;j<N;j++)
a[i][j]=temp[i][j];
return ;
}
void fun(int nn)
{
memset(res,0,sizeof(res));
for(int i=0;i<N;i++)
res[i][i]=1;
while(nn){
if(nn&1)
mul(res,a);
mul(a,a);
nn>>=1;
}
return ;
}
int main()
{
while(~scanf("%d %d",&n,&mod)){
memset(a,0,sizeof(a));
for(int i=0;i<N;i++)
scanf("%d",&a[0][i]);
for(int i=1;i<N;i++)
a[i][i-1]=1;
if(n<10) printf("%d\n",n%mod);
else {
fun(n-9);
int ans=0;
for(int i=0;i<N;i++)
ans+=res[0][i]*(9-i)%mod;
printf("%d\n",ans%mod);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: