您的位置:首页 > 其它

POJ 2484 A Funny Game(规律直推)

2017-08-14 14:24 309 查看
Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 106) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must
be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.) 


 

Figure 1

Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.) 

Suppose that both Alice and Bob do their best in the game. 

You are to write a program to determine who will finally win the game.
Input

There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input. 

Output

For each test case, if Alice win the game,output "Alice", otherwise output "Bob". 

Sample Input
1
2
3
0

Sample Output
Alice
Alice
Bob
题意:n个棋子围成一圈,A和B轮流拿走1个棋子或者2个相邻的棋子,注意:假设棋子是4个,2被拿走后,1 3不相邻。
思路:总结发现规律,后手在足够聪明的时候学先手下棋即可。
#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int main()
{
int n;
while(scanf("%d",&n)==1&&n!=0){
if(n>2)
printf("Bob\n");
else
printf("Alice\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  博弈论