您的位置:首页 > 其它

The Suspects(并查集)

2017-08-14 10:21 211 查看
Think:

感觉 有点想 判断 强连通节点数目的 方法。

社团中 第一个孩子不处理, 从第二个孩子 开始 与 第一个孩子进行连接

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4

2 1 2

5 10 13 11 12 14

2 0 1

2 99 2

200 2

1 5

5 1 2 3 4 5

1 0

0 0

Sample Output

4

1

1

#include<cstdio>
#include<iostream>
#include<string.h>

using namespace std;

int Find(int x);
void Merge(int a, int b);

int pre[1008611], a[1008611];

int main()
{
int n, m;
while(cin >> n >> m && (n || m))
{
int i;
for (i = 0; i <= n - 1; i ++)
pre[i] = i;

for (i = 0; i <= m - 1; i ++)
{
int k;
cin >> k;
if (k >= 1)
{
cin >> a[0];
for (int j = 1; j <= k - 1; j ++)
{
cin >> a[j];
Merge(a[0], a[j]);
}
}
}

int cnt = 0;
for (i = 0; i <= n - 1; i ++)
{
if (Find(i) == pre[0])
cnt ++;
}
cout << cnt << endl;
}
}

int Find(int x)
{
int t = x;
while(t != pre[t])
t = pre[t];

int i = x, temp;
while(pre[i] != t)
{
temp = pre[i];
pre[i] = t;
i = temp;
}

return t;
}

void Merge(int a, int b)
{
if (Find(a) != Find(b))
pre[Find(b)] = Find(a);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息