您的位置:首页 > 产品设计 > UI/UE

POJ - 1679 The Unique MST

2017-08-14 08:46 183 查看

题意:
判断最小生成树是否唯一,如果唯一则输出最小生成树的值,不唯一则输出“Not Unique!".次小生成树的模版。

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 

1. V' = V. 

2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all
the edges in E'. 

Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the
following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output
3
Not Unique!

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int p[105][105];
bool vis[105];
int lowCost[105];
bool used[105][105];//标记该边是否是最小生成树的一条边
int maxx[105][105];
int pre[105];
int n, m;
int prim()
{
int ans = 0;
memset(vis, 0, sizeof(vis));
memset(used, 0, sizeof(used));

for (int i = 1; i <= n; i++)
{
lowCost[i] = p[1][i];//默认1为起点
pre[i] = 1;
}
vis[1] = 1;

for (int i=1;i<n;i++)
{
int minn=99999999;
int minPos;
for (int j = 1; j <= n; j++)
{
if (!vis[j] && lowCost[j] < minn)
{
minn = lowCost[j];
minPos = j;
}
}
ans += minn;
vis[minPos] = 1;
used[pre[minPos]][minPos] = used[minPos][pre[minPos]] = 1;

for (int j = 1; j <= n; j++)
{
if (vis[j] && j != minPos)
maxx[j][minPos] = maxx[minPos][j] = max(maxx[j][pre[minPos]], lowCost[minPos]);
if (!vis[j] && lowCost[j] > p[minPos][j])
{
lowCost[j] = p[minPos][j];
pre[j] = minPos;
}
}
}

return ans;
}

int main()
{
int t;
int u, v, w;
scanf("%d", &t);
while (t--)
{
scanf("%d%d", &n, &m);

for (int i = 1; i <= n; i++)
for (int j = 1; j <= n; j++)
p[i][j] = 99999999;

for (int i = 1; i <= m; i++)
{
scanf("%d%d%d", &u, &v, &w);
p[u][v] = p[v][u] = w;
}

int MST = prim();
int MST2 = 99999999;

for (int i = 1; i <= n; i++)
{
for (int j = 1; j <= n; j++)
{
if (!used[i][j])
{
MST2=min(MST2, MST + p[i][j] - maxx[i][j]);
}
}
}

if (MST != MST2)
printf("%d\n", MST);
else
printf("Not Unique!\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: