您的位置:首页 > 其它

HDU 1443 Joseph

2017-08-14 01:49 302 查看

Joseph

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3048 Accepted Submission(s): 1719
Problem Description

The Joseph\\\\\\\'s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will
be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be
saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
 

Output

            The output file will consist of separate lines containing m corresponding to k in the input file.
 

Sample Input

3
4
0


 

Sample Output

5
30


原题链接:点我
题目大意:约瑟夫环,有k个好人和k个坏人 编号从1,2,3....2k,前k个为都为好人,后k个都为坏人,按照约瑟夫环的排除方法即每次从m个人中排除第n个人,求在能够满足在不排除一个好人的情况下排除所有坏人的最小的n

解题思路:打表+模拟约瑟夫环  因为数据k只从1-13所以一定要打表 不然会超时

重要的是模拟约瑟夫环

设每次排除的人的位置为p 人数为m,排除第n人

判断p的位置是否大于k 或者为0,每排除一次人数都减1

代码:

#include <stdio.h>
bool Joseph(int m,int n)
{
int k=m/2,p=0;
while(m>k)
{
p+=n%m;
p=p%m;
if(p>k)
{
p--;
m--;
}
else if(p==0)
{
p=--m;
}
else return false;
}
return true;
}
int main()
{
int ans[14],m;
for(int t=1;t<=13;t++)
{
for(int t1=t+1;;t1++)
{
if(Joseph(t*2,t1))
{
ans[t]=t1;
break;
}
}
}
while(scanf("%d",&m)&&m)
{
printf("%d\n",ans[m]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: