您的位置:首页 > 产品设计 > UI/UE

HDU - 3836 Equivalent Sets(强联通分量)

2017-08-14 01:35 357 查看


Equivalent Sets

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 104857/104857 K (Java/Others)

Total Submission(s): 4781    Accepted Submission(s): 1720


Problem Description

To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.

You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets.

Now you want to know the minimum steps needed to get the problem proved.

 

Input

The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000.

Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.

 

Output

For each case, output a single integer: the minimum steps needed.

 

Sample Input

4 0
3 2
1 2
1 3

 

Sample Output

4
2
HintCase 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.

 

Source

2011 Multi-University Training Contest 1 - Host by HNU

 

Recommend

xubiao

题意:给出n个点和m个点之间的子集关系,问要至少加几个条件才能使它们 互相成为子集。

分析:

题目 可以转换为,要加多少条有向边才能使图成为强联通图。

所以求一下强联通分量,然后缩点,记录一下缩点后图每个结点的出度和入度,取最大的那个就是答案。

AC代码:

#include<stdio.h>
#include<string.h>
#include<stack>
#include<vector>
#include<algorithm>
using namespace  std;
const int maxn=50050;
vector<int>v[maxn];
stack<int>S;
int dfn[maxn],low[maxn],viss[maxn];
int index,cnt;
void init(int n)
{
for(int i=0;i<=n;i++)
v[i].clear();
memset(dfn,0,sizeof(dfn));
memset(low,0,sizeof(low));
memset(viss,0,sizeof(viss));
index=0,cnt=0;
}
void dfs(int x)
{
dfn[x]=low[x]=++index;
S.push(x);
for(int i=0;i<v[x].size();i++)
{
int y=v[x][i];
if(!dfn[y])
{
dfs(y);
low[x]=min(low[x],low[y]);
}
else if(!viss[y])
{
low[x]=min(low[x],dfn[y]);
}
}
if(dfn[x]==low[x])
{
cnt++;
while(1)
{
int s=S.top();S.pop();
viss[s]=cnt;                //缩点
if(s==x)
break;
}
}
}
void solve(int n)
{
for(int i=1;i<=n;i++)
{
if(!dfn[i])
dfs(i);
}
}
int in[maxn],out[maxn];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)==2)
{
init(n);
for(int i=0;i<m;i++)
{
int a,b;
scanf("%d%d",&a,&b);
v[a].push_back(b);
}
solve(n);
for(int i=1;i<=cnt;i++)
in[i]=out[i]=0;
for(int i=1;i<=n;i++)
{
for(int j=0;j<v[i].size();j++)
{
int b=v[i][j];
if(viss[i]!=viss[b])
{
in[viss[b]]++;
out[viss[i]]++;
}
}
}
int inn=0,ott=0;
for(int i=1;i<=cnt;i++)
{
if(!in[i])
inn++;
if(!out[i])
ott++;
}
if(cnt==1)
printf("0\n");
else
printf("%d\n",max(inn,ott));
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: